• Avatar
    Ryan P

    Hello,

    I believe this is a system issue. Since your default language is set to one language. When typing in another, it looks like it's wrong to the system. 

    There maybe a system setting on your iPhone that allows you to turn off spell checker. This would (I think) fix the issue.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    No. iOS does not work in that way. In fact, if I use any standard keyboard, the problem does NOT occur. Whatever is the default language, iOS uses the correct proofing tool depending on the keyboard language. For example, if your default language is English and you write in Spanish by using a Spanish keyboard, no problem. But if you use Swiftkey and you selected TWO languages for it, that is, English and Spanish, the iOS proofing tool does not know in which language you are writing and assumes one out of the two idioms. In fact, Swiftkey allows you to write in two languages from the SAME keyboard (assuming they share the same character set). So, the Switkey developers should find a way to tell iOS to use both dictionaries, but I do not know if that is possible. The problem is the red underline is really annoying. Turning off the spell checker is NOT an option, since I can use them in any moment by switching to any keyboard but Swiftkey.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    I tried editing my message but it did not seem to work. What if you add a second language to your system. 

    I heard from the devs that said this is something on the OS side and it's something we can't fix.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    I regularly use 4 languages: English (40%), Italian (40%), Spanish (10%) and French (10%). My default language for interface is English. I have five keyboard: EN, IT, ES, FR and Swiftkey with two languages set: EN & IT. 

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Iamdaymo

    Dario, in this sense you are correct in the fact that on the stock ios, the words are not underlined. However, this is not something that I have seen whilst using Swiftkey on ios even up to the latest ios 10. Can you screen shot any of the issues, and I will try to mirror the issues you are having pls??

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    This is not only on iPhone. I have installed Swiftkey on OnePlus 3T with android and I have the same problem. Red underline. I`m using 3 languages.

    With google keyboard spellcheck works, but not with Swiftkey.

    Turning off the spell checker is NOT an option, because I need it.

    Best regards,

    Sergey

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    So official answer for Android, because another thread was closed immediately.

    "spell checker is only available for the language that Gboard uses or the SYSTEM language. This feature is not available for 3rd party keyboards."

    That means spell checker WORKS in Swiftkey, but only for system Language, so only one language at time. :(

    It would be cool, if devs can solve it, and Swiftkey says to system, wich language is now default.

     

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    I also have this issue - the text I type is underlined in red if I write in a language different than English using SwiftKey with iOS. If you switch to the stock Apple keyboard for that other non-English language and then back to SwiftKey, the red lines disappear. So it seems the issue is with iOS not being able to see which spellcheck to use with SwiftKey. However, this workaround is not memorized and switching from app to app (especially iMessages that handles each contact with their own Apple keyboard based on previously used language), red lines will reappear with SwiftKey under each word. It is a recent behavior and a little annoying, even if does not try to autocorrect to English.

    I wish SwiftKey would get a significant update for iOS - two years that nothing happened and that we are limited to two languages without shortcuts, gestures, or trackpad on iOS.

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Just turn off the spell checker under phone general settings. Autocorrect of SwiftKey will work and will do its job. The only way of getting rid of the red underline was by switching off the spell checker. 

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    yoni Gavish

    I have the same problem with a new Huawei P10 lite running EMUI 5.1 (Android based). I have english as my main language and hebrew as my secondary language. spelling works fine on gboard for both languages, but in swiftkeys all the hebrew words are red underlined. adding words to the dictonaries don't solve the issue -the same words are still underlined in red after retyping them. It doesn't happen if using the gboard. Would be great to have fix or workaround for this. All the fancy stuff doesn't really add anything if the basics are not sorted. it is really annoying...

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Itai Assaf Raizman-Greif

    I have the exact same problem. I see it's been going on for months. Is there no official response yet?

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    This happened to my two phones only when using the latest version of SK BETA, switching to gboard or any other keyboard fixes the issue.

    I have a galaxy note 3, and a xiaomi note 4

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    I'm having the exact opposite problem on my S8+.

    When I use the standard Samsung keyboard I get the wrong words (I mainly use german and english keyboards 50:50) underlined in red.

    When I switch to SK, these underlines are gone. :(

    I've activated spelling correction in the system settings, as this works with the Samsung kb.

     

    Any suggestions what could be wrong?

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Even that the problem appears only in SwiftKey, but when i uninstalled GBoard it was fixed,

     

    1
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.