• Offizieller Kommentar
    Avatar
    Alpert

    Hello,
    SwiftKey autocorrect is always on except for text box for typing codes.
    Most users need this function and that's why we keep it.

    If you think SwiftKey does wrong autocorrect, please notice that the suggestion on the left side is what you actually typed. So instead of hitting the space bar, you can tap on the word you typed and untouched by SwiftKey, and insert it to the text box. 

    Alpert

    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Factually true, sure. But a hell of a lot more painful than if it just preserved the word that I typed.

    Do I need to open a new topic to ask how I can uninstall SwiftKey, or can you answer that here?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Alpert

    No matter it preserves or not, there's always one tap you'll need. Maybe to me it's effortless.
    Anyway, sorry to hear about you're going to uninstall SwiftKey. To do that, please make sure that SwiftKey is not a pre-installed app on your device. Then you can go to phone setting, apps, find SwiftKey, then tap uninstall. If it's pre-installed, you'll need to contact the OEM for further instructions.

    Alpert

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Is there any way to prevent certain words from being autocorrected? Specific examples in my case: its and it's. I seem to be one of the few people who actually know when to employ these correctly. So I don't want SwiftKey to "fix" my "mistakes" (but thanks for trying to help ☺️).

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Alpert

    @Josh, you can turn off the autocorrect.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    @Alpert, I *LIKE* your autocorrect ... it's usually great! So I don't want to turn it off. I would simply like to fine-tune it as described. Thanks.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Alpert

    I get it, but SwiftKey is a keyboard, not a mind reader, I hope you can understand it. In some situations it will miss-judge things. 

    The example of "it's" and "its" is the best case, obviously we use "it's" more often, so SwiftKey would choose this as the primary suggestion. Even we have functions to allow you to forced insert "its" rather than "it's", but I guess it won't be very convenient.

    But, if you want it forced to be "its" (or force to insert your personal words rather than auto-correct), leave a comment below and I'll show you.

    -3
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    I'm spending a lot of time in a game chat where we talk about a character called a titan. The first time I used this term I called it a Titan (with a capital T). I don't want this term capitalized and I've selected the uncapitalized version many times by it still uses the capitalized version as the default. As a result I used the capitalized version frequently when I don't want to. Is there a way I can change the default to the uncapitalized version?

    As you might guess, being to fix an autocorrect like this will be helpful for a lot a situations, not just this one.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Alpert

    @Alan,

    If you type type letters "t-i-t-a-n", I'm sure the prediction on the left is the "titan", in the middle it's maybe "Titan" you talked about. All you need to do is tap on the correct one rather tapping on the space bar. 

    Another solution is to remove "Titan", so that you can have "titan" in the most situation; and if you need "Titan", just one tap on shift key to capitalise the prediction. 

    As I said earlier in the post, SwiftKey (as well other keyboard) may not able to tell the difference, and it may take the personalized word more importantly in the dictionary.

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    I've been selecting the uncapitalized version (titan) on the left whenever I remember (which is most of the time). How do I remove "Titan". Do I backspace it out and then type "titan" in? If I do this will auto correct change it to "Titan" again?

    Thanks very much for your quick response.

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Alpert

    To remove a specific prediction:

    long-press (tap & hold) on that prediction then tap "remove" on the pop-up window.

    You are welcome.

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Thanks very much

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    See, I have an issue while using the SwiftKey keypad. It predicts a word and then at times shows a label across the word. If I do not select any option and tap at the end of the word, the keypad disappears and I have to delete the word again and again. I tried undoing it from my phone settings also. But disabling the autocorrect setting does not do away with this option. Can you please help?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Hi

    I too am finding issue with how to undo an undesired autocorrect. I am fairly sure that another keyboard I have used undoes the autocorrect if I backspace after it was applied. This would solve a lot of the above issues (I feel) and certainly be good for me! And very sad to hear that swiftkey isn't a mind reader; if you don't get on to reading minds you will be left behind :)

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Hi,
    I like autocorrect and want to use it. But it keeps changing a certain word I use, and add all sorts of word endings. The word is in Hebrew ("לא"), and it means "no",which is naturally used quite a lot. And SwiftKey keeps adding endings to this word, and keep changing it totally to unrelated words. (words such as academy, and other unrelated words which starts the same in Hebrew).
    When I removed the first prediction, I got a new prediction starting with the same letters.
    I would like an option to say - Do not correct this word at all. (and not just - do not correct it to word x, because if I say so, it corrects it to word y or z instead).
    Is there a way to do it, that is to ask SwiftKey to not correct a certain specific word?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Here's an interesting one. SwiftKey autocorrect most always changes the simple word "a" to "à"... yes, the letter à with a French accent grave... even when I'm writing in English. I've told SwiftKey a zillion times to no longer predict "à" but it doesn't pay heed. What can I do?

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    I used to be able to close my eyes and type out a sentence 90 to 95 percent correct (thanks to Swiftkey s older autocorrect tech)

    But for the last year or so, that just hasn't been possible

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Throw Away

    Boy alpert, nice attitude you have here. How dare people that use this keyboard have problems with it - they must be just using it wrong, right?

    I have the same problems as a lot of people here. Input something specific, that doesn't need correction, and swiftkey thinks is spelled wrong. Have to press space to keep typing, but pressing space autocorrects the word. No way to just skip autocorrecting that one, single word. That doesn't seem either too hard, or too unreasonable a request.

    Also, the "long press to forget a word" still doesn't work at all. I can do it over & over & over, or will still recommend the wrong word, or a capitalized version I tell it not to. It's really really broken, and had been for a long time. You're lucky no one's made a competitive keyboard, is try it in a heart beat.

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Throw Away

    The typos above never happened nearly as much using either tap typing or "flow", nice to see the "improvements"

    0
    Aktionen für Kommentare Permalink