• Offizieller Kommentar
    Avatar
    Alpert

    Hello,

    The currency symbol does not depend on keyboard language but your phone system language. 

    Alpert

    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Dear Swiftkey developers,

    This issue is quite frustrating for me. Been using beta for a while but there's no solution yet. :(

    I'm in Singapore, Singapore uses UK English but our currency is in $.

     

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Alpert

    Hi there,

    To insert a currency symbol, all you need to do is to long-press on "x" key then slide to the one you need, or in "123" page, long-press on the "£" key and also slide to the one you need. I'm afraid this is the solution for now because we do not have English (Singapore).

    At the same time, you're welcome to submit a request by following this post.

    Best

    Alpert

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    This issue still exist after all these years! Please add function to fix a currency symbol permanently or add a language for English (Singapore) thanks!

    1
    Aktionen für Kommentare Permalink
  • -2
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    That's not a solution, it's a lack of a solution.

     

    Not every Android handset allows the user to specify a Locale in such a way that SwiftKey will display the appropriate currency symbol.

    So to use that as the basis for the default symbol instead of the language pack the user installs for SwiftKey itself (or at least have an option to override it) is utterly perverse.

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Michael Ho

    The problem still persists. I'm a user in Australia

    3
    Aktionen für Kommentare Permalink
  • Avatar
    Ser Go

    I switched from Galaxy s7 to xiaomi and have the same issue. Xiaomi doesn't have English (Ireland) as an option of system language. The nearest is English (UK), that why default currency sign is £ but not €.
    In fact there is only 3 English speaking countries listed - UK, US, India.
    While it's obvious phone manufacturer's issue, SwiftKey could have developed a fix to override this setting..
    Hope one day...

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Guan Ming Teo

    Massive ooft, this is 4 years old and still no fix?

    Regards,

    Australia

    1
    Aktionen für Kommentare Permalink
  • Avatar
    David Charles

    I had the same problem. You can change the keyboard via the 'Languages and input' settings.
    This is how I fixed it on my Xiaomi Redmi phone.

    1. Settings

    2. Additional settings

    3. Languages and input

    4. I changed the language from English (UK) to English (Australia) and it worked.  If you are not in Australia and want the $ sign to appear, change it to English (US)

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ser Go

    But that ⬆️ only changes from £ to $, stil there's no option for € to be displayed 😐

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Deniz K

    Hi Ser Go, the currency key responds directly to the language/locale that the phone is set to, regardless of the language model/layout in use in SwiftKey. So if your phone language is set to English UK, you’ll get a £; if it’s English US, you should get a $ (and Yen with Japanese, Euro with French/Spanish/German and so on).

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ser Go

    Deniz K,

    Thank you, Figured that out a year ago, but in my Xiaomi there is no locality available for English speaking EU country, so no € sign available on the keyboard. That is the issue with the phone.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Deniz K

    Hi Ser Go have you tried English (Ireland)? Can you share a screenshot of your options when you long press on the currency key?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ser Go

    English (Ireland) option is not available in Xiaomi Mi 9T.
    Once pressed currency key I can see $¢£₽¥€
    It seems that I can't upload screenshots here, so I have them in Flickr :
    https://flic.kr/ps/3W1Kv4

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Deniz K

    Hi Ser Go if the language is not available on your device, I'm afraid there's not much we can help with as this would be related to your device. You may want to try to contact your device manufacturer for this. In the meantime, please long press the currency key to select €.

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    Jan Klos

    Same problem here. I am Czech, but am using Android in English. I can't believe an option to force a (default / short-tap) currency symbol regardless of locale setting is still not implemented, after all those years...

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Deniz K

    Hi Jan Klos what is your device language and which currency symbol are you looking for please?

    0
    Aktionen für Kommentare Permalink