• Avatar
    Radu Apostu

    Glad to see I'm not the only one...Please fix this! It's really frustrating!
    And guys, vote please ! Go up to the title and on the right, next to it you will find a number with arrow up and down..hit arrow up ! Hopefully someone will take this under advisement.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    I solved using the smart keyboard, where the period key can be disabled (joy)

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Diego Medeiros

    Tnks Marco Tecno!

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Kevin Gill

    is there a solution for this yet?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Literally about to uninstall swiftkey because of this. I've been using swift key for years and honestly I'm not sure why I've used it for so long. This is the last straw for me. Time to find something else.

    As others have said, removing the dedicated emoji icon helped but I'm still doing it more than enough to drive me nuts. I'm also sick of how poor SwiftKeys auto correct is. If I had a nickel for every time swiftkey changed a correctly spelled word to a different correctly spelled word that I didn't type I'd be a millionaire. Such a stupid feature. "oh you typed on? You must have meant no. Let me fix that for you"

    What a waste of money this app was.

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Pascal Bouffard

    I switched to the Google keyboard, at least the spacebar is on the right side, so I don't have the "." Issue anymore...too bad swiftkey

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Diego Medeiros

    Microsoft bought SwiftKey and now bought GitHub. R.I.P. GitHub

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Has anyone tried the Cheetah keyboard? Wanted something different to Swiftperiod & Gboard so just downloaded from the Play Store and so far it seems excellent. Not hit the period button once, lovely themes, decent auto correct and seems all around very easy to use. Worth a try guys 👍

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Rommel G

    8 months from. the first post and still no answer or solution from SwiftKey? I have always. loved this app but frankly this. issue will steer me. away (left the dots on purpose. to. show you how many corrections I need to make on my texts)

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    I've deleted SwiftKey, reinstalled it, deleted it, reinstalled it all because of this one minor yet infuriating detail. Even more annoying that SwiftKey won't acknowledge or fix it. I got a Huawei p20 pro and SwiftKey is surprisingly the default keyboard. It's shit that SwiftKey won't fix it but it's still the best keyboard IMHO... SwiftKey just fix the fucking full stop/period thing please???

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Have to admit the Cheetah keyboard eventually wore me down, what a load of crap, so returned to SK as even with the STUPID glitch it's still the best one out there. If only they'd fix it 🙄

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    *bump*

    I would love a response from the dev team

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Chris Langill

    I believe the issue is that they broke out the full stop key from the full stop/long press punctuation key and cannibalized the rightmost part of the space bar in doing so. It's annoying AF but I've found no usable alternatives. Each competitor has deal breaking quirks for me.

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    We're not sure why this issue is happening. We've not made any changes to the space bar location/size or the punctuation key.

    ** the space bar got a little bit smaller with adding the dedicated emoji key** if that setting is on, but that makes the left side of it smaller. 

    Everyone seems to be hitting on the right side (this side should not be impacted in size). 

    Can anyone create a few videos of the issue happening. Az screen recorder is a good app, there is a setting that allows you to turn on "key presses" so we can see where you are actually hitting the screen. 

     

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Please simply implement a setting to hide period key and enlarge the space bar. Please!!!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Kevin Gill

    Just recorded my typing and didn't hit the full stop once.  Have you made a change?  Or was I just subconsciously not hitting the period so it didn't look like it was on purpose?

    I have disabled the dedicate emoji button for a while and this helped a small amount, but I was still having problems until now.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    There have been no changes to this area besides the dedicated emoji key as I mentioned. 

    We did make a change to how quick period works. It is now more time based, you have to hit the space bar in a certain amount of time to trigger the quick period. 

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    The problem is hitting the period key INSTEAD of the space bar, when typing with two thumbs.

    Please implement a setting to hide the period key... Please.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Chris Langill

    The problem occurs in landscape mode. I f you notice the punctuation key in portrait mode, the full stop (period) is the primary key shared with a long press common punctuation key. In landscape mode, the full stop key is at the right most followed by the multi punctuation key. I don't know if the full stop was given its own key or not but that is what the issue is. For a wide grip, the natural strike point of the thumb is where that full stop key is. The solution is to aggregate those two keys again (like they are in portrait mode) and lengthen the space bar to the right. I'm sure it would not be difficult to implement. That key type exists in portrait mode and it would just be a matter of resizing the space bar.

    I can't point to when something changed in landscape mode (which is all I use having big hands) but something changed. I've never had so many issues with full stop as I've had for the past few months. I only decided to search for the issues a few days ago to see if I was going crazy or not. Clearly, others are having this issue.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    Chris, 

    Can you share screen shots please, I'm not seeing what you are saying. I personally never use land scape, so you may have some other layout settings changed.

    Is everyone else having the same issue with Landscape, or are we dealing with a few different scenarios here?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Kevin Gill

    I agree the problem is mostly in portrait mode. Typing in game chat is the worst. My clan mates think I have a case of full stop tourettes.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Me: I'm hitting period key in vertical mode, using two thumbs. My right thumb goes on the period key instead of going onto the space bar. As simple as that.

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Chris Langill

    @Ryan P

    I can snap some screen shots for sure. How can I get them to you?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Paul Merecicky

    Portrait mode is the problem.  I never use landscape.  I'm usually a one-handed typer when using my phone.  Landscape mode on a smartphone is useless for busy people.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    It's super lame, but you have to force desktop view in order to see the image attachment feature. Or you can upload them to any service you want and drop the link in here.

    A video of the issue happening would be far more powerful. 

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Ryan P,

     

    See here for a sample video - https://www.dropbox.com/s/wjiw7yegbqvcyqq/2018_06_26_15_48_35.mp4?dl=0

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    Ryan (nice name)!

    I was watching the video, and it seems like you are definitely just hitting the period key. I was thinking maybe the period key was being triggered by accident. I'm seeing the punctuation key being highlighted representing a tap.

    I also see in your video that you have the dedicated emoji key turned on, was this issue happening for you before this key was there? Have you tried turning it off?

    There could still be an issue where the period/ space bar hit area is some how overlapping and causing this. 

    While there are quite a few people here having the issue, it seems to not be that wide spread. 

    I wonder if this is related to a specific OS/Device and even language.

    This is why we do ask for device details, some bugs are very specific to device and OS.

    Others on this thread having the issue, does everyone have the dedicated emoji key turned on?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    I'm on a Pixel 2. I'll turn off the emoji key and report back in a few days.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Samsung S8 no emoji key. Unwanted period all the time. Would love to have the option to turn the period off and just have long press for punctuation. Period is unneeded anyway with double space period on.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Note 8, always on portrait mode. This period stuff is simply ridiculous. I was (am!) struggling with it for months until I decided to start looking for a solution and found this forum.

    How many regular users do that? 0.01% probably.

    Please fix this, this is the best keyboard and it's so annoying.

    0
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.