• Avatar
    Ryan P

    Why is this such an issue for you?

    Automatic language switching is one of the key features of SwiftKey that a lot of our users love. 

    Perhaps there is a bug with some of the languages you are using?

    -9
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Thanks,

    Here is why it is an issue for me.

    My native language is Persian. I live in USA. Almost all my texts are in English. But I also have Persian Keyboard because I write in Persian often (but not as much).

    Up until some time ago I would switch to Persian in case I needed it. I was happy using Swiftkey and I was fast. I would just type in words and Swiftkey would clean up after me. It was a blast. I even installed it on my FireHD. I recommended it to almost everybody. But at some point you mixed English and Persian.

    Now if I write "Hey" in my texts and I mean "Hey", it suddenly changes into "هی" which would freak out my American friends.

    Up until now, I was able to misspell a word and be sure that Swiftkey will correct it for me. But now, in some cases it will find a random word in Persian and instead of correcting the English word, swap it with a Persian word.

    I assume this feature might be useful for some, but not all and I got really disappointed when I saw that I am forced to use it and there is no way to switch it off.

    I would switch back to Swiftkey (I'm using Google Keyboard now) in a heartbeat if you just add the option to turn off multi-language prediction and stick to the keyboard language. Google keyboard sucks at correcting my spelling errors. I miss Swiftkey.

    16
    Aktionen für Kommentare Permalink
  • Avatar
    Ryan P

    Hi there,

    Thanks, this clears things up. We introduced a Persian Transliteration language model - so what you noticed is the app switching script too easily and yes, making it super annoying for some.

    This is something we are aware of and will be looking into. We don't have a time-line for a fix.

    This is not an ideal work-around, but what you can do is download SwiftKey beta and only use Persian on there and then English on normal market SwiftKey. 

    This would allow you to use SwiftKey in both languages, but not have them mix up while typing. 

    It's the best solution I have for right now while we work on more language updates. 

    -7
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Hello there,

    I write daily in 3 languages. Italian, Spanish and English.
    Swiftkey auto predictions continuously misudenrstand the language I am writing into making a mess. I had to stop using it a go back to google keyboard.
    Searching the forum I found many like me: asking for a "select language prediction" option.
    Or else, please give me my money back.

    10
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    Rayan P,
    I would definitely like to use this feature but not every time. This should be added as an additional keyboard in stead of replacing the english keyboard.

    4
    Aktionen für Kommentare Permalink
  • Avatar
    Eckhard Doll

    Same here with German and English. This is highly annoying - especially as you can easily switch between languages manually.

    4
    Aktionen für Kommentare Permalink
  • Avatar
    Siavash Malekpour

    I vaguely remember a popup box asking me if wanted predictions for both languages. Not knowing what I got myself into I tapped yes. That means somewhere internally in your software you keep track of who wants this feature and who doesn't.

     

    Adding something to the setting to turn it off would benefit everyone.

    3
    Aktionen für Kommentare Permalink
  • Avatar
    Siavash Malekpour

    Also, why is this marked as "Answered"? It's not. Is there a bug report somewhere on the site we can follow?

    4
    Aktionen für Kommentare Permalink
  • Avatar
    S Dejan

    Hi,

    I just installed SwifKey because of multi-language requirements. I also don't like not having the option for ON/OFF with particular language. The beauty of Serbian language that you don't need spelling and it's just annoying. Alternative would be Touchpal's keyboard who solved this problem with easy solution.Having button ON/OFF next to the space bar, but I would recommend you to DO NOT install it because this app got ADS even with payed version. So, I would say this isn't a bug of  SwifKey rather I would call it : " Feature request" . 

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    It is still not solved. I hate this feature, get rid of it or give me an option to turn it off

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    I don't know why you added such a garbage option to this nice keyboard app and continue wasting our time by removing unwanted suggestions.
    Why don't you listen to your users and make this optional?

    4
    Aktionen für Kommentare Permalink
  • Avatar
    NANDAKUMAR M S

    It is an irritating feature to say the least. Why should this be default that can not be Barred? Option seems to be removing all but one only.

    3
    Aktionen für Kommentare Permalink
  • Avatar
    Mattias Molin

    I agree. This setting is needed. 

    I personally write in Swedish and English. I use different QUERTY layouts; one for english and another with åäö for Swedish.

    I keep getting wrong autocorrects. Especially when writing in Swedish. As an example that keeps happening all the time is when I write in Swedish, i is replaced by I (i.e. lower case i is replaced by uppercase). This is very annoying and keeps happening even if I keep correcting the autocorrect.

    We need to be able to turn it off. No bilingual input and then switching language by swiping the space bar is sufficient and better.

    At the moment, I solved it by using Swedish only, and using GBoard for english. I might switch to GBoard permanently.

    It should be a setting.

    4
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    I think they have finally listened to us on SwiftKey beta app. There is an option under typing transliteration enabled, disable it and it will no longer auto correct to 2nd language

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    Can't see it under typing. Which version are you using?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    https://www.dropbox.com/s/3ck4tlej4ibnge7/Screenrecorder-2018-06-15-18-25-33-430.mp4?dl=0

    Check this out

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    7.0.7.26 beta

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently Deleted User

    You're right. Thanks.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Sheraz Uddin

    Hi everyone, those who are annoyed with autocorrect on other language, here's how to disable it
    Go to SwiftKey tap typing then tap on typing and autocorrect, disable Transliteration,
    Voila! Auto correct from one keyboard to other language is disabled,

    -2
    Aktionen für Kommentare Permalink
  • Avatar
    S Dejan

    Hello Sheraz,

    I can see from the link and video posted above, option for Transliteration. It  was available on beta version which I'm not using. Now I am on higher,working built v. 7.1.9.24 but that feature is not there? Could you confirm current version of your app or any tip how did you come around it.- TIA.   

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Pooya764

    Remove this garbage option

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Rouge W.

    This feature is unproductive. I spend more time trying to make SwiftKey change back to the original language I was swiping on than actually swiping. I swipe in English and Spanish, and any loanword makes it change forth and back.

     

    Please make it optional. Please.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Pooya764

    Wonderful!!! Android has this option for turn on or off !!! But in ios no!!!!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    iridium flare

    Same problem when using Urdu language along with English. Have switched to Google keyboard for the time being. Would love returning to SwiftKey as long as this problem is fixed.

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Jan Bilek

    Why is this marked as answered? The problem still persists, the option to switch it off mentioned by some people is not present in latest production version. It's such a shame because it makes great keyboard so frustrating that it is unusable for me.

    2
    Aktionen für Kommentare Permalink
  • Avatar
    Mattias Molin

    I agree. This should not be marked as "Answered". Simply because no one seems to be able to confirm the answer/solution except some of us that noticed a (temporary?) setting in a beta (that did not seem to make it into the following/final/public releases).

    The setting seem to have existed in the 7.0.7.26 beta. I am also currently on 7.1.9.24 and this setting is a no-show.

    The problem is neither answered or, for that matter, fixed (in case there is a bug/TR opened).

    Anyone knows of there is a bug/TR, or possibly a feature request or similar reported on this?

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    After one year of using Google Keyboard (which by the way is not bad at all) I am back to SwiftKey. You finally added the option to disable transliteration and I'm back as promised.
    Thank you.

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    iridium flare

    I am back to SwiftKey after they added the option to disable transliteration.
    Had to use Gboard for one week.

    -1
    Aktionen für Kommentare Permalink
  • Avatar
    Jan Bilek

    @hojjat abdollahi or @iridium flare, could you please send screenshots? AFAIK I have the latest production version (no updates available) and I cannot see any "disable transliteration" option.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Permanently deleted user

    I didn't see it at first either. It appears when you add the second language.

    0
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.