• Avatar
    Alpert

    SwiftKey fixed the problem of unnecessary auto-space in address bar of browser. I just tried in Chrome with SwiftKey 7.1.4.18 and there's no auto-space after the dot no matter what I typed. Same for the email addr. 

    But I can confirm this problem exists with words like e.g.

    1
    Comment actions Permalink
  • Avatar
    Permanently deleted user

    yes, you're right, it was all good for a short time.

    But currently, 7.1.4.19 is installed on my devices and the problem is back again :-(

    1
    Comment actions Permalink
  • Avatar
    Permanently deleted user

    I think, the problem was never completely solved. It still appears in browsers, using combined search/address bars. 

    Then, every input is handled as normal text, not as a URL and auto spacing is not deactivated. 

    Only when used in browsers that have a plain address bar (without search function), e. g. Chrome, auto space seems to be deactivated.

    All this is very annoying! Why can't they just integrate a settings option to let the user decide, whether he wants auto spaces or not? 

    2
    Comment actions Permalink
  • Avatar
    Jean-Marc Van Ravels

    Indeed, this is absurd. Each time I want to write an email address I have to remove the blank first in order to add the domain name after the at-sign. Please add an option to disable the auto-insert of a blank after DOT.

    Now name@domain.com will always become name@ domain.com ! So if you forget that swift auto inserts a blank your mail will never arrive or be sent wrongly.

    4
    Comment actions Permalink
  • Avatar
    Stefan Sonderegger

    Yes, please fix this. Maybe with a global option to disable/enable. As this is really annoying for every time I have to wire a mail address (even twice for my usual login address), Web URLs and many other situations. I know SwiftKey from my Windows phone, while this is one of several 'improvement features' which makes for me personally the swift-typing on Android at least 75% less effective than it was on Windows phones. (to name just few of them e.g. the auto-language / all Uppercase instead of lowercase, when press shift-key after Auto-uppercase / not delete complete word while pressing backspace, in case swiftkey has recognised the wrong word / no quick change of word between all uppercase, all lowercase, first-letter uppercase by simply mark an existing word an press shift key).

    4
    Comment actions Permalink
  • Avatar
    Matt Sullivan

    This is a huge, ignored use case. SwiftKey won't allow users to enter a web address without requiring a backspace (. com). It's a glaring issue. Great keyboard, been using (and backspacing) for years. It's time to fix this - PLEASE. This affects every single web address entry...not trivial.

    Same with colons - I type the hours & minutes frequently (e.g. 6:00 am) and have to backspace after the colon.

    4
    Comment actions Permalink
  • Avatar
    Brano P

    I've reported this another time, still hoping after several years, that someone starts to care:

    https://support.swiftkey.com/hc/en-us/community/posts/360056058431-Don-t-add-a-space-after-a-dot-period

    1
    Comment actions Permalink
  • Avatar
    Permanently deleted user

    I fear, this will have been a useless effort.

    They do not seem to be interested in the opinion of their users.

    During the last few months, they published nearly daily updates introducing hundreds of new languages (that most probably noone needs), but they do not understand a simple problem like the one, which was described here.

    For the time being, I banned Swiftkkey from my device, using other alternatives...

     

    Thanks anyway for the initiative!

    0
    Comment actions Permalink