• Comentario oficial
    Avatar
    Alpert

    Hi,

    The 3-dot punctuation is called Ellipsis. 

    It's available by entering 123 key and long-press on the period key.

    Also, tap 3 times period key will also insert an ellipsis, the dots behind will delete the space of the dot before.

    Alpert

    Acciones de comentarios Permalink
  • Avatar
    Permanently deleted user

    i hate this auto spacing...i wish theres an option that can turn it on or off

    1
    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    i agree, please put an option to disable auto punctuation. ps: the official comment is beside the point

    1
    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    Quoto. Is too difficult for you create an option for disabilite the automatic space after point???

    1
    Acciones de comentarios Permalink
  • Avatar
    Permanently deleted user

    You need to provide us with the option to turn off auto spacing after inserting a punctuation

    0
    Acciones de comentarios Permalink
  • Avatar
    Permanently deleted user

    So many people asked about it... but nothing happened... this annoying problem makes me to leave the SwiftKey keyboard... sorry but no other way... don't wait for an update, the developers seem to ignore this because so many threads the last years over, but nothing has changed

    0
    Acciones de comentarios Permalink
  • Avatar
    Bronson Coutts

    Despite having the option to turn off automatic spacing, entering an ellipsis even with this feature turned off automatically deletes the space beforehand! It's antagonising me unbelievably. I even tried enabling the "Double tap the space bar to insert a period" feature. Alas, failure! ... The only way I can get this to work (mind you an ellipsis is only grammatically correct if it is used WITH an leading and preceding space) is to enter my desired three periods to form an ellipsis, allow the keyboard to auto-correct (incorrectly), then navigate back to where the space should be with my cursor and insert the space, before navigating back to the end of my typing to continue.

    0
    Acciones de comentarios Permalink
  • Avatar
    Brano P

    I've reported this another time, still hoping after several years, that someone starts to care:

    https://support.swiftkey.com/hc/en-us/community/posts/360056058431-Don-t-add-a-space-after-a-dot-period

    0
    Acciones de comentarios Permalink
  • Avatar
    Simon Rozman

    In Slovenian, the ellipsis is non-contiguous. It must have a space before it. This makes Swift keyboard actually producing grammar mistakes while autocorrecting.

    Second, I cannot use DuckDuckGo's bangs with autocorrecting punctuation spacing. They require an exclamation mark before the bang keyword. Autocorrection moves the exclamation mark after the previous word.

    To me, this spacing autocorrection is the single most annoying feature of the Swift keyboard.

    Uninstalling the Swift keyboard for now, but keeping notification on from this thread, should this be fixed.

    0
    Acciones de comentarios Permalink