• Comentario oficial
    Avatar
    Ryan P

    Hello VIPs,

    Here is the official knowledge article we have on this issue:

    This issue only affects SMS. When sending a standard SMS message, emoji takes up more than one character. This is related to the way the character is coded, and is the way all standard SMS works with emoji.

    If you are seeing your characters per SMS decreasing when using emoji, it is because SMS does not have a 160 character limit, it has a 140 bytes limit. Usually messages are encoded using GSM 03.38, which uses 7 bits per character so you end up with a 160 character limit.

    When you write emoji your SMS app most likely switches to using UTF-16, which uses 2 or 4 bytes per character and which gets you an upper limit of 70 characters. If you only use characters that are encoded as 4 bytes, you can at most write 35 characters. The upper limit can be even lower if you use combining characters (for example diacritic marks).


    https://support.swiftkey.com/hc/en-us/articles/201458012-Why-do-emoji-on-Android-take-up-more-than-one-character-

    Everyone is pretty right on the matter though. It is not up to us but the device and the SMS client being used. Emoji are a unique thing. You can always do a Google search to learn more about them if you'd like.

    I hope this helps.

    Best,

    Ryan

    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    Hi

    Since the update a few days ago, when I insert an emoji into a text regardless how short it is, the SMS is automatically converted into an MMS. I was unaware this was happening until I ran out of credit and texts stopped sending.

    I am currently with Tesco Mobile UK and get charged for every MMS. How do I stop this happening? I cannot see any settings on my Samsung S4 to stop this, only a warning that the SMS has been converted.

    Thanks, Keith 😢

    I think it might be text app dependant on whether it's sent SMS or MMS. It's most likely converted to MMS to increase compatibility. So for people who don't have emoji can still see it.

    Sent from my Sprint Galaxy S5 using Tapatalk Pro

    0
    Acciones de comentarios Permalink
  • Avatar
    Brandon O'Berry

    Sorry to hear that this happen for you, Keith. As another Galaxy S4 user, "allow me to shed some light on the subject."

    EZ is correct here, in that the stock messaging app for Samsung devices does this by default, to increase compatibility. When emoji is inserted into a message, it is automatically converted into an MMS to guarantee that your recipient(s) will be able to both receive the message and see the emoji (as some devices cannot naturally). Unfortunately, there isn't an option in the settings to turn this off. To prevent this from happening, there is a far right tab in the SwiftKey emoji keyboard that features the classic " : - ) " smilies. If you wish to continue using that specific app, please use that tab, and your messages will stick as SMS.

    Rest assured, there is a workaround! Most third-party apps have it configured to where an SMS can be sent with an emoji. However, this causes your messages to shrink to a maximum of 70 characters instead of the usual 160 (this is cause by the coding involved). A good start would be to use Google Hangouts, but there are plenty of other useful apps that'll do just as well as the Samsung messaging app.

    0
    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    Hello Max,

    i tried on my Alcatel and mixed standard with new emoticons. Verified SMS type , didn't changed into MMS (you almost gave me a heart attack 😄

    0
    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    Hi, I'm using Samsung Galaxy S III mini and I think I might know the solution for your problem. If you go to your message app, and go to settings you can choose your 'input mode' (I don't know if it's called like that in English, it's just above your MMS settings). You have to click it and choose 'unicode'. That solved the problem for me, I don't know if it will for you.

    0
    Acciones de comentarios Permalink
  • Avatar
    Brandon O'Berry

    As it would seem, this option was scratched for me after updating to Android 4.4.2. I do remember the option, but it is no longer present, even after setting the app as my default.

    0
    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    As it would seem, this option was scratched for me after updating to Android 4.4.2. I do remember the option, but it is no longer present, even after setting the app as my default.

    Oh okay, I didn't know that. My phone is still running 4.1.2.

    0
    Acciones de comentarios Permalink
  • Avatar
    Permanently Deleted User

    Thanks for the advice S3MiniHolder, but I tried that option along time ago as it has been mentioned in other threads. Sadly it is the same regardless of what input method I select.

    Running on 4.3 if that makes any difference.

    Is there anybody on this forum who represents Swiftkey and is in a position to give a definitive answer?

    Thanks

    0
    Acciones de comentarios Permalink