• Avatar
    Permanently deleted user

    Mine started doing this yesterday on my Pixel but only on the website it started breaking on. It is fine here and other sites and apps but this is what I get on the one site: Testung out phone keyboard agaun. Did ut fixfifix ? Nope. NotNeveythNot eeisebriken

    After reboot & reinstall: Testing out the reinstall of SwiftKey. IIdudntI I liginllogin loginl.

    I reinstalled beta with same result. I tried not logging in to my swift account but no change there either. Gboard works normal on that website.

  • Avatar
    Permanently deleted user

    OK wow. I'm glad others are facing issues. Up until 30th Feb things were fine. But then on one website it's impossible to type. Auto corrections aren't working. Even if I click on a suggested word it will often just add another letter randomly to my word or not add a space etc.

    It's fine on WhatsApp and many other apps, and all other websites. Wtf!

  • Avatar
    Permanently deleted user

    After some serious searches I found others having the same issue on one single forum. For many of them it appeared to be a problem with the Rich Text Editor not cooperating with different keyboards, including stock Samsung/Gboard/etc not just SwiftKey. Disabling that on those forums seemed to fix it. Not an ideal fix though because obviously people like their RTE :)

    It's an SMF forum that I mine occurred on and I turned off the "Show WYSIWYG editor on post page by default" option. Not only did it fix the problem for me on my Pixel but it also fixed the completely different formatting issue I have had on my PC when typing a post. I've lived with that absolutely awful problem for so many years without finding a solution but had just given up. The change is just miraculous for me. lol

    Hopefully this will help anyone else popping into this thread even if only a temporary solution. GL!

  • Avatar
    Permanently deleted user

    Interesting, when I post with BBcode on my forum instead of rich text editor it works fine.

    Did you find that this is browser dependent? I had no issues on Firefox when doing a quick test. I am confused why there are suddenly issues and wonder how many users are impacted.

    Hopefully it is patched in an update to Chrome or SwiftKey or something...

  • Avatar
    Permanently deleted user

    I am having the same issue on my pixel XL with the post editor on rdforum dot org.
    Predictions are putting in the first character of the word I typed when I hit space and it's just being weird in general. It's not doing it on this site but it definitely is on the other.

    Thanks for reporting it, I hope SwiftKey figures it out 😁

  • Avatar
    Permanently deleted user

    Hi, this is a major reproducable bug - steps to reproduce:

    1. Use Android Chrome version 64, visit e.g. a XenForo-based forum with Rich-Text-Editor like this one: https://www.android-hilfe.de/

    2. Try to write a post or a reply using SwiftKey. (Be aware that registration for this forum is needed)

    Result: Predictions will be nonsense, some keys will write wrong letters

    Further testing:

    • Issue shows up with update to Chrome 64. There have been changes to JavaScript in Chrome 64 in order to protect against malware "spectre".
    • Disabling JavaScript in Chrome 64: You will see no problems anymore. But this cannot be a solution.

     

    Please fix this issue, thanks!

  • Avatar
    Permanently Deleted User

    I am so glad i'm not the only one having this issue. It has made the keyboard correction and prediction functions nearly unusable.

  • Avatar
    Permanently deleted user

    It's independent of the editor,, I guessg it's something with chrome updates. Same predection errorerin disqus, on reddit, or even here as you can see it.. ItsI even worse when you use accented chacharacte. 

  • Avatar
    Permanently deleted user

    Yes, I think that I was rash to blame SwiftKey... I've experienced a similar (but not quite as bad) situation with other keyboards I've tried instead.

  • Avatar
    Permanently deleted user

    It's jjst really hard to typt amyanythi. IveI tried to open a thread on reddit  but the mods deleted it. I hope someone find a fix soon. It's a pain in my... 

  • Avatar
    Permanently deleted user

    Don't see why you have an issue on here though when it's fine for others. Equally I'm surprised more people aren't complaining.

    So does a fix need to come from Google if it's chrome related then and not swiftkey.

  • Avatar
    Permanently deleted user

    Just try to Google iti, there are other forums where people report this issue with SwiftKey (I googled rhkthway) . As you can see , a cery few people read this forum. Anyway Swype has no problem at least on my Xperia the old Swype based xperia keykeybo has nnonissues... Okay it's just ridicridic

  • Avatar
    Permanently deleted user

    Please see my last comment above for a temporary solution. It's not just SwiftKey unfortunately. I haven't tried it on another browser yet but It still has fixed everything for me.

  • Avatar
    Permanently deleted user

    DisabliDD Rte editor would be a fine thing, but neither in disqus, neither on reddre or here there is no option for that. Disabling Javascript disables comments to appear as well. So there aren't any globally usable solution. 

  • Avatar
    Permanently deleted user

    Thanks to the previous posters for describing this problem. I was beginning to think the problem was forum-related, or maybe just Disqus. I only have the problem on Disqus, but am not much of a prolific poster, so I didn't have any different sites to compare it to. I knew I had no issues on any app or website, only Disqus forums. It's mind-numbingly annoying as I've become so automatic in my typing that by the time I look at what I wrote, I though maybe I was having a mental breakdown. I took some screenshots, but my problem is the same as others have illustrate above. For example, when typing 'around', I usually start with 'ar' then press the autocomplete word 'around'. I end up with 'araround'. If I start typing 'discussion' I type 'disc', press the autocomplete word and get 'discdiscus'. Sometimes the result is more goobledygook, even when pressing the space bar or a period. I guess we'll see what happens. 

    *Edited original post. I noticed that it doesn't finish a long word, as in 'discussion' above. I originally wrote that swiftkey would finish it as 'discdiscussion', but more accurately, it would finish as 'discdiscus'. Seems like there might be a max amount of characters it will add, in addition to the other unintelligible gibberish it sometimes fills. 

  • Avatar
    Ryan P

    Hello everyone, 

    We are looking into this. 

    If everyone can respond back with their versions of Chrome and what websites they are able to reproduce this on, it would be helpful.

     

    best,

    Ryan

  • Avatar
    Permanently deleted user

    Thanks Ryan
    Version 64.0.3282.137
    And http://www.audi-sport.net/xf/forums

  • Avatar
    Permanently deleted user

    Not sure what you meant by, 'respond back'. I replied to the support email I received and am double-posting the info here in case this is where you wanted it...

     

    Chrome version: 64.0.3282.137 and phone/android build LGMS631/MRA58K and 6.0.0. A website forum example is twitchy.com, the disqus comment section contained in any article.

     
    Thanks for your response.
  • Avatar
    Permanently deleted user

    I see you seem to have isolated this to Chrome. I can confirm that, with me, Firefox and Swiftkey don't seem to manifest this problem. Thanks.

  • Avatar
    Permanently deleted user

    64.0.3282.137 and I guess earlier version as well, Marshmallow 6.0.1, any site with disqus, reddit, your swiftkey forum.

  • Avatar
    Permanently deleted user

    This is not only happening in English. It also occurs in Spanish, on certain websites.

    I'm glad to know that I'm not alone. Hopefully, SwiftKey will fix it soon.

    It's impossible and really annoying to write on some sites.

  • Avatar
    Permanently deleted user

    I'm experiencing the problem mainly on an online forum based on xenforo software.

     

    It's odd - a standard, light tap causes the problem to manifest itself. A slightly firmer, longer tap seems to work OK. (Too long a tap results in the "Remove Prediction?" pop-up)

    I'm really sorry but I am having real difficulty identifying exactly what is going wrong - because it seems inconsistent.

    Sometimes it seems like pressing a suggestion from the row of three options at the top of the keyboard inserts the option to the left of what you select in its entirety.

    Currently I am typing the word "Your"

    When I have typed "yo", the three suggestions are:

    you yo your

    If I select "Your", it inserts "yo" and I am left with "yoyo"

    I have tried repeating that exercise by deleting everything apart from the first "y", typing the letter "o" and then pressing each of the suggestions.

    Selecting "your" usually results in "yo" being added (with the resultant word being typed, "yoyo")

    Sometimes it inserts "you" (resultant word "yoyou") and sometimes "you" (resultant word "yoyou"). Occasionally it works as expected and completes the word - "your"

    I hope this is of use, and you can get it fixed - it's funny how much you take something you rely on for granted until it breaks!

     

     

     

  • Avatar
    Ryan P

    While we look into this, can you all please also report this to Chrome so they can perhaps take a look as well. 

    I will use this thread to keep everyone updated. 

    Thanks,

    Ryan

  • Avatar
    Ryan P

    Sorry everyone.

    Another quick update. In order for us to squash the bug, we need more help. The devs have asked for a few more specific things.

    1) Again, please list some sites you come across that this is reproducible on and preferable ones that do not require a log-in

    2) If you can capture a video of the bug (there is a free app called AZ screen recording), which i use and it's great. You can send the link here, upload id to YT as a private video, whatever you prefer. 

    This would be much appreciated and would make SwiftKey work in Chrome, once again. 

     

    Best,

    Ryan

  • Avatar
    Permanently deleted user

    Hi Ryan

    https://www.youtube.com/watch?v=Dh-lHs3x5zY  - here you go, it started off quite well actually but then got worse. This was me typing slowly and when there are issues it is after having pressed the spacebar.

     

    https://www.youtube.com/watch?v=9qD2WxVOlU4  in this video at 1:10 I turn off the rich text editor and type at a faster speed, no issues.

    This was on Audi Sport net that I linked earlier in the thread however it does require registration...

  • Avatar
    Permanently deleted user

    https://youtu.be/w2lunGEKStc

    This shows the space bar entering the first letter of the last word typed at random.

    Google Pixel XL on 7.1.2 and chrome version shown during the video

  • Avatar
    Permanently deleted user

    https://youtu.be/rhVCQe14dA4  

    I turned on 'Show Touches, so hopefully it will aid in viewing what I pressed vs what was displayed. 

    Since I think this error occurs almost exclusively within forums, I think one has to register most of the time. 

     

  • Avatar
    Permanently deleted user

    @Ryan:

    See and use this demo page for rich text editor, no login required:

    https://kevinroth.com/rte/demo.htm

    Btw: I actually also encounter the issue, while writing this Post here, using your rte editor. Edit: But editing some hours later works

  • Avatar
    Permanently deleted user

    I'm also experiencing this issue.

    Chrome: 64.0.3282.137

    SwiftKey: 6.7.6.20

    Site: www.webcadets.com/forums/ (running XenForo) no login required for help forum

    Video: https://youtu.be/aT9HHpn6qos

  • Avatar
    Permanently deleted user

    Could someone please advise how to most effectively report this to Chrome?

     

    I'm guessing this is the route to take:-

    https://support.google.com/chrome/answer/95315?hl=en&co=GENIE.Platform%3DAndroid

    In that link they state:-

    Add details, including steps to help us recreate the issue you're experiencing.

    Choose if you want to include more information in your report, like a web address, your email address, or a screenshot.

    What's the best way of ensuring that they don't dismiss this as a Swiftkey issue rather than a Chrome issue?

Veuillez vous connecter pour laisser un commentaire.