• Официальный комментарий
    Avatar
    Alpert

    Voice input is not processed by SwiftKey but by Google Voice Input.

    Your internet speed, phone processing power, and numerous possible reasons might slow it down, but SwiftKey itself is not one of them.

    Действия с комментариями Постоянная ссылка
  • Avatar
    Doug Steinberg

    I'm having this issue as well as numerous people on the pixel support forums. Voice typing with gboard works as expected but with SwiftKey there's a 3 to 5 second delay or more. This manifested when I switched from pixel 2xl to 4xl...

    0
    Действия с комментариями Постоянная ссылка
  • 1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Kraig Blamires

    Alpert your answer doesn't explain why when I switch my default keyboard to Gboard the voice to text is literally instant. However, while using SwiftKey it's about a 5 second delay. What's going on with SwiftKey that I'm getting a long delay?

    3
    Действия с комментариями Постоянная ссылка
  • Avatar
    Alberto Cabas Vidani

    I am having the same problem. Did someone solve it?

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Mike Guarino

    I am also having the identical issue.  Only slow with SwiftKey.  We can't be the only ones having this issue! 

     

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    brian hurley

    All I had to do was read the "official response" and the "answered" tag.  Regardless of intention, it shows serious disregard for your userbase.  

     

    It took 10 minutes in the developer tools to locate the issue.  Your app may not process the audio, but it is responsible and I have to assume that you know why, if I was able to locate the issue that quickly. 

    2
    Действия с комментариями Постоянная ссылка
  • Avatar
    Kraig Blamires

    Has anyone figured out how to use Swiftkey without having a 5 second delay in voice input?

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Alberto Cabas Vidani

    I installed GBoard

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Scott Watts

    I am experiencing the same issue.  Voice Input with GBoard is instant, with SwiftKey it is delayed to the point of not being usable.  Something changed around February 2020 (guessing when I first noticed) because it was fine until then.

     

    The SwiftKey response for this thread is not acceptable.  If it were merely a bandwidth issue, then it would also affect every other keyboard application, but it only affects Swiftkey.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Clay Coffman

    While I don't think this this post was handled well by SwiftKey Support, I'll go ahead and post what fixed it for me since Google might lead others here. It would appear that Gboard uses something other than "Google voice typing" input, since the issue did not happen while using Gboard, only with SwiftKey.

    For me, this was caused by enabling a setting that sounded harmless for the way I use my phone. Check here:  Apps>Google>Settings>Voice>"Bluetooth audio recording" - turn this off. In my case, turning it on immediately causes the issue.

    Others have posted elsewhere that having Live Caption enabled produced a similar issue. Check here:  Phone Settings>Accessibility>Live Caption - turn this off. If you use a non-pure Android OS, this may vary and you'll need to find Live Caption in your device's settings.

    2
    Действия с комментариями Постоянная ссылка
  • Avatar
    Ed B.

    To Brian Hurley
    Agreed , definitely a SwiftKey problem. Please let us know where you found your solution in Developer tools? I scoured my developer options and couldn't see where I could "fix" SwiftKey...

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Kraig Blamires

    Clay I tried both variations and neither of them work. I still have a substantial delay. It might be slightly faster, but the difference is negligible. Any other updates to this issue? It sucks that I paid for SwiftKey and I don't use it because of this issue.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Scott Watts

    As Clay Coffman posted above:

     

    "Check here:  Apps>Google>Settings>Voice>"Bluetooth audio recording" - turn this off."

     

    This resolved the issue for me.

    0
    Действия с комментариями Постоянная ссылка
  • Ahhhhh! This dude! Clay Coffman nailed it!!! I've been trying to figure this out for weeks. I couldn't stand to switch keyboards bc I'm such a creature of habit. It's too foreign to use anything else. But I absolutely HAVE to have accurate V2Text for work. Enough so I was about to just eat shit to deal with the change and Switch to Gboard even though I hate it for typing. But after trial and error, after error, and more error.....this simple little thing fixed it! All hail the Coffmeister!!!!!

    TURN OFF BLUETOOTH AUDIO RECORDING

    0
    Действия с комментариями Постоянная ссылка