• Avatar
    Durga Nallam
    Hello, Jennifer. Sorry to hear that you are having an issue with Double space in SwiftKey. We are aware of the issue and currently investigating it. Sorry for the inconvenience.
     
    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    Just to be clear, the issue isn't with double spacing, but with adding punctuation after a word from the three suggestions above, such as when I do this . or this , or this !

    2
    Действия с комментариями Постоянная ссылка
  • Avatar
    Michael Dunlap

    Also having the double-space after punctuation, regardless of setting. Glad to hear it's being investigated, as the last week or so have been annoying to manually change spacing from how I've been using for years.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    Michael, that's not the same problem I'm having. Mine is before punctuation after tapping on a suggested word (the words at the top of the keyboard), like if I wrote this message to you without correcting it, it would look like: Michael ,that's not the same problem I'm having . Mine is before punctuation after tapping on a suggested word (the words at the top of the keyboard ), like if I wrote this message to you without correcting it ,it would look like :

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Durga Nallam

    Hi Jennifer Could you please let us know, if the Auto space is enabled in the SwiftKey app. Please go to SwiftKey app and click on settings > tap on Typing and then check for the Auto space.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    Durga, Auto Space is not enabled. As I said in my first post, the app somehow automatically enabled it one day, so I had to go back and turn it off because it was putting single spaces after periods (I properly use double spaces) and I'm too used to typing my spaces in to change.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Simon Jones

    When you tap a suggested word it adds a space after it . Type punctuation next and the space used to be removed . It no longer is, giving space punctuation space, which is incorrect.

    If you type punctuation it adds a space . If you then type a space , it used to be ignored . It no longer is , giving two spaces after the punctuation, which is incorrect.

    Something has changed , and it needs to be changed back, quickly. Thanks.

    2
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hi there, thank you for briefing the issue. Currently, we are investigating an ongoing issue with the 'Quick period' feature. So, we suspect that this behavior is a result of the ongoing issue. We will forward this feedback to our concerned team for further evaluation. We appreciate your bearing with us in the meantime.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Sean May

    I'm having the same issue as Jennifer and Simon. It's very annoying.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    Yes, Simon, exactly the first part you said is what I'm having the issue with. Thank you. I don't know about the space being ignored after part since I never have used the automatic space after a period feature and I do use two spaces after periods, which I type in myself since I've been doing so long before smartphones and tablets.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    Hari, thank you. I'm not sure what the "quick period" feature is, and I probably don't use it, but to be clear, it happens with all punctuation, not just periods.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Claudia van Wasbeek

    When can we expect the issue with two spaces after comma and period to be resolved? Thanks.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Simon Jones

    @Hari, I have always had the Quick Period feature turned off. I still see extra space before punctuation and/or two spaces after punctuation as I described before.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hello Jennifer, Simon Jones 
    Could you please try to update your Microsoft SwiftKey app to the latest version and check if you are experiencing the issue again? Thank you!

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Simon Jones

    Hari Kyasa I think the problem has been fixed, thanks. I noticed it was better a few days ago but wanted to monitor it for a while before saying anything.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    @Hari I just updated it to the September 1st update (auto update is on, but it never updated or even showed in the list of apps that had updates available!), but the problem still exists . As you can see there . And there. Very frustrating!!

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hello Jennifer, our apologies for the trouble. If possible, could you please try to record a video of the issue happening and send it over to us via https://aka.ms/sk-support. and we will be able to investigate further. Thank you!

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Jennifer

    @Hari Okay , I will send you the video of me typing this. You will see that when a predicted word is used , the punctuation does not go right next to it, but it does when just typed . Like this is predicted . This is not. Thank you !

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hello Jennifer, Thank you for your effort. We see that you have submitted a support ticket with the video. We'll follow up with you there. Thank you!

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Sean May

    I've uninstalled and reinstalled SwiftKey and it's still having the same problem, so I'm just going to uninstall it and use something else - I've been trying out Typewise.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hello Sean May, our apologies for the trouble. If possible, could you please try to record a video of the issue happening and send it over to us via https://aka.ms/sk-support. and we will be able to investigate further. Thank you! 

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Michael Brock

    I'm experiencing this exact issue and I'm on the latest update (or at least no update is showing as available; 8.10.25.4).

    As reported several months ago, this just started happening.  If I select a suggested word it adds a space after it.   If I then type a punctuation key it does not remove that space.   "Auto Space" is not enabled.

    If I type the word or use flow, it  does not add a space at the end of the word until I start typing/swiping the next word, at which point it adds a space before that next word.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hello Michael Brock, thanks for reaching us. At the moment, It is expected behavior on the SwiftKey keyboard that an automatic space is followed. When a word is inserted by tapping on the prediction bar or by using flow typing. To bypass the automatic space between the predicted word and punctuation. We request you enable the 'Auto-Space' option in the SwiftKey app settings. So that, whenever the punctuation is entered after the predicted word. The punctuation deletes the auto space and inserts it right next to the predicted word. I hope this helps. If you have questions, please don't hesitate to get back to us. Thank you!

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    KM Anger

    There needs to be an option to turn off the automatic space after a predicted word or aut corrected word. It's very annoying and impossible to type. The suggestion to enable Auto Space after punctuation to automatically delete the space is a bad one. I cannot type with auto space after punctuation because if I want to enter a number with a decimal, I get 12. 34 instead of 12.34. Also, entering web addresses comes out like www. Microsoft. Com. We should be able to turn off Auto Space after punctuation and also be able to turn off Auto Space after predicted words.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    elyshh

    The spaces between predicted words and punctuation are caused by the way that SwiftKey keyboard works. When you type a word, the keyboard will try to predict the next word you want to type. If it predicts correctly, then it will automatically insert a space between the two words. However, if it doesn't predict correctly, then it won't insert a space.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Hari Kyasa

    Hello KM Anger, At the moment SwiftKey keyboard does not have a workaround to bypass this behavior. Please be assured that we will certainly pass your feedback along to our team. 

    We apologize for any inconvenience this may have caused, and we thank you for your support.

    0
    Действия с комментариями Постоянная ссылка