• Avatar
    Alpert

    Thanks for the report.

    I'll reach the team to share your post.

  • Avatar
    Alpert

    Our mod team cannot reproduce your problem.

    It works well on iOS 11 beta 8 anyway.

  • Avatar
    Ryan P

    What I believe is happening is you are pressing and holding on the keyboard, which is activating the cursor control. When this is triggered, the keyboard goes blank as you showed in your screen shot. 

    All you have to do is swipe on the space bar to switch layout. 

    I was able to do this on an iPhone 6S, running 10.3.3.

  • Avatar
    Jamil Dybwad

    I am using Android. When selecting Norwegian in the language selection pref., I had to choose the Norwegian lay-out alongside Norwegian language and German keyboard lay-out alongside German language. In the prefs it says in grey below the language, "Tap to change ..." When you tap, up come the different lay-outs and you scroll through. 

  • Avatar
    Dhaval Yoganandi

    I am facing same problem as OP suggested. I am using iPhone XS Max and Running latest version of iOS 12.0.1. I am trying with Canadian English and Gujlish  language. There is no way to switch the layout. Please fix the issue.

  • Avatar
    David Thornton

    Swiftkey for iOS only supports a maximum of two languages at a time. Add a third and you’ll be informed that you can’t activate more than two simultaneously.

    The tap to change layout option only appears if the two selected languages have differently configured keyboard layouts in the SwiftKey iOS app; for example QWERTY for English and QZERTY for Portuguese. If both languages are set to use the same keyboard layout then no menu will appear when a light press is made on the keyboard.

    To be clear there is no facility to manually select which language dictionary SwiftKey uses. The app itself will decide which language it thinks you are tying in and make appropriate suggestions. Personally I’d prefer a manual override on this last feature.

  • Avatar
    Dhaval Yoganandi

    I understand, David. Then why am I not able to type in Gujarati transliteration? 

  • Avatar
    David Thornton

    Can you be more specific about about what you mean by "switch the layout"? Do you mean you want to manually select the language dictionary or do you want to change specific keys on the keyboard?

    The only thing that can be manually switched is the specific layout of the keys. QWERTY is default but some people use other layouts. QZERTY is where the Z is placed where the W is on the keyboard layout. 

    I myself would like to be able to manually select the dictionary language. I use both English and Portuguese. Sometimes I get suggestions for misspellings in the wrong language.  

  • Avatar
    Ryan P

    Hi David,

    There is no way to switch between actual languages. When you have more than 1 downloaded, each language is active at all times. 

    If one language has a specific/different layout, i'd say it's more likely that words in that language are predicted than the other. 

  • Avatar
    Dhaval Yoganandi

    Hello David,

     

    I am using Gujlish language. And when I am typing, it doesn't translate in Gujarati but it shows English instead.

  • Avatar
    N Kverenchkhiladze

    Hello,
    I have exlactly the same issue, I am using two keybord languages, English and Georgian. I simply used to change the keybord symbols by sliding the spacebar. Now when I am typing in one language it gets stuck and I can't switch back to another. I need changing languages all the time during the day so this issue is a big discomfort. To fix it, every time I need to go to swiftkey settings, turn off one of the languages and then turn back it on.
    If you know the solution to this problem, please inform me.
    Thanks

  • Avatar
    Kris Meyer

    Jamil's solution worked for me. Thank you. :)

  • Avatar
    Peter Toky Tokarčík

    David,
    you are right. I had QWERTZ pn all three languages so I changed to have Slovak and Czech QWERTZ and English to QWERTY and now I am able to quick switch using the space bar. Thank you for your advise!

Yorum yazmak için lütfen oturum açın.